読者です 読者をやめる 読者になる 読者になる

CentOS7 Samba で Windowsから共有フォルダにアクセスできない不具合

ファイルサーバの引っ越しを行ってきました。

 

弊社の拠点はVPNで接続されており、

社内LANとしてどの拠点にも気軽にアクセスできる状態です。

 

先日ある拠点のファイルサーバの引っ越し(windows10 のフォルダ共有→CentOS7 Samba) をおこない、クライアントのWindows10PCから接続してみると、

ユーザー、パスワードの入力画面が表示されるまでに 30秒以上かかり、襲時には1,2分かかっていました。??????

まあ、そのうち調子が出るのではないかと、頭をかしげながらその拠点のクライアントPCの設定をすべて終えました。

別の拠点に引っ越し完了をつたえて、パスワードを再設定してもらおうとすると、

なぜか全くアクセスできない。

試しに、私が勤務している拠点(勤務センターとする)のPCにリモートデスクトップでログインし、Sambaの共有フォルダにアクセスをこころみましたが、できませんでした。

ping も通らない。

前日まで勤務センターのPCからリモートでファイルサーバの設定を行っていたので何ともおかしな話です。

変わっているのは、IPぐらいのものですが、セグメントは変えていないし、

???アクセスできない意味が分からない。

 

意味が全く分からないので、引っ越しは断念、すべて元に戻してみんなに謝って帰りました。

サーバは持って帰り調査です。最悪すべて再インストールするしかないな、と思っていました。それでもだめならば、機器の初期不良か・・・。

 

不審だったところがいくつか。

1 IPを変更後にreboot したが、いつまでたっても起動しなかった。

  モニタを接続してみると、エラーメッセージが出て固まっていた。

 

2 サーバを設置した拠点のクライアントPCからはアクセスできるのだが、

  パスワード入力画面が出てくるのが異常に遅い。

3 VPNでつながっているほかの拠点からはアクセス不能。PINGも通らない。

 

1の再起動失敗は、OSのアップデートで起動しなくなったことがあったので、

無効にしているはずのカーネルのアップデートがされてしまったのか、

それとも機器の不良で不安定なのか・・・。

2、3は・・・意味が分からないが、LANケーブルの断線、HUBの不良、ルータのキャッシュの不具合を考えました。

 

どちらも間違い。

1は、おそらく途中でぶち切ってしまったシェルスクリプトが動作していて、

起動できないのではなくて、シャットダウンできない状態にあったようです。

エラーメッセージは a stop job is running for ・・・・・で、

タイムアウトにもならずに延々と待機していました。

一度強制終了してから、起動、そしてもう一度再起動すると、普通に起動するようになりました。

2,3はなんと、

一つのLANポートに2つのIPアドレスが設定されていました。

それも2つ目は別の拠点のIPでセグメントも違っていました。

これは、一度GNOMEIPアドレスをいじっていた時に、なぜかなってしまったようです。

一度デバイスを削除してから、Modifyしなおしたら治りました。

GNOMEでのIPアドレスの変更や追加は、やらない方が無難なようです。

 

かくしてファイルサーバの引っ越しは完了。ようやく終わりました。